Wordpress automatische updates kapot

Wordpress

Wij hosten duizenden Wordpress websites. Enkele weken geleden werd een foute versie vrijgegeven door Wordpress, waardoor voor vele sites de automatische updatefunctie niet meer werkt.

Wat is er aan de hand?

Wordpress is software om websites te beheren, één van de meest populaire zelfs. Andere voorbeelden zijn Drupal, Magento, Joomla, ...

Wordpress werkt constant aan deze software en brengt nieuwe versies uit die functionaliteit brengen maar ook beveilingslekken fixen. Vooral voor die beveiligingslekken is het dus van het grootste belang dat je je Wordpress-installatie up-to-date houdt. Daarom heeft Wordpress ook al jaren een automatische update-functie voorzien. Zo zal je website constant zichzelf updaten, zodat je op 2 oren kan slapen.

Maar! In versie 4.9.3, die vrijgegeven werd op 5 februari 2018, zat een fout die deze automatische updates kapot maakte! Dus als je Wordpress (al dan niet automatisch) bijgewerkt is tot versie 4.9.3, is de kans groot dat daarna de automatische updates niet meer werken.

Ik wil mijn site niet updaten!

Dat begrijpen we. Want je site steeds updaten naar de laatste versie betekent soms ook dat dingen wijzigen die je niet wil. Bijvoorbeeld de layout die verandert of een plugin die niet meer naar behoren werkt na de update.

Toch is het van het grootste belang dat je dit doet, want als je het niet doet, wordt je site vroeg of laat gehacked. Lees in dit verband ook ons eerder artikel 'website hacks voorkomen en genezen'.

Dus neen, je hebt geen keuze! Je Wordpress zal up-to-date moeten blijven. En door het probleem dat we hierboven beschreven, is mogelijk je automatische update kapot en is er actie vereist.

OK dan. Wat moet ik doen?

Gelukkig is het niet zo moeilijk wat je moet doen. Je gaat gewoon naar het admingedeelte van de website, en klikt op Dashboard -> Updates.

Als er staat:

De meest recente versie van WordPress is geïnstalleerd. Toekomstige beveiligingsupdates worden automatisch geïnstalleerd.

Dan ben je goed. Je moet minstens versie 4.9.4 hebben.

Als je meer wil lezen over de exacte oorzaak, kan je dat hier vinden.

Vragen of opmerkingen?

Laat het ons zeker weten via onze chatbox!
We helpen je graag verder.

Deel deze blog via

Andere topics